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2 Prizmatix LED-Ctr|-STBL Software Description

The Prizmatix LED-CTRL-STBL (Control) software was developed to enable convenient control and
stabilization of output power for UHPTLCC-02-STBL LED controllers on Windows based computers via a
USB connection.

The USB enabled Prizmatix LED sources can be also operated by sending a simple text string via serial
communication COM port from various software packages such as MicroManager, MetaMorph,
LabView, Matlab, HyperTerminal and many other software packages. APl and code examples are
available upon request.

3 Health and Safety

Prizmatix products are NOT authorized for use as components in life support devices or systems.

The Prizmatix LEDs are intended for use as laboratory
equipment only.

It is not cleared or authorized for clinical use.

4 Setup of the Hardware

For setup of the hardware (LED head, LED controller etc.) please refer to the specific LED illuminator
User-Manual. In this document only software related aspect will be discussed.

Please ensure that you have received appropriate USB cable to connect the LED controller to the
computer.

5 Software Setup

The Prizmatix-LED-CTRL-STBL system setup is performed in following steps:
e Download of the compressed software (ZIP file).
e Setup of Prizmatix-LED-CTRL-STBL software
e Setup of USB device drivers

Do not connect the USB cable to the computer until
completing the software setup process.
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5.1 Download of the Compressed Software

The software is available at Prizmatix website:

prizmatix.com/software.htm

Please refer to the software related label on the bottom of the LED controller. The label indicates the
specific link that shall be used for download.

Click on the link, you will see the ZIP file inside Dropbox.

Click on the small menu [==#] at right side of the ZIP file name. As the menu opens chose Download.
The ZIP file will download to your default download folder

Typically: C:\Users\YourName\Downloads

Open the download folder and right click on the ZIP file, a popup menu will open.

Chose Extract All..

Extract Compressed (Zipped) Folders

Open

Open in new window

B SharE Wlth Skype C:\Users\Lab2\Dropbox\Lab2-Computer\Prizmatix_LED_Ctrl_Setup| Browse...

Ej(tl'act All... [#] Show extracted files when complete

Hin to Start

Select a Destination and Extract Files

Files will be extracted to this folder:

Extract Cancel

The following dialog box will appear. By default, it will suggest creating a new folder in your
Downloads folder, which is typically good practice. Press Extract button to continue.
The ZIP extraction will create new folder Prizmatix LED Ctrl Setup inyour Downloads

directory.
= | Prizmatix_LED_Ctrl_Setup
Home Share View

T ‘ “Prizmatic_LED_Ctrl_Setup

Mame
# Quick access

@ bin
BB Desktop )
o license
b ] ¥ Downloads 3 supportfiles
: Documents L1 dp.pmi
= Pictures idist i

o2 Lab2-Computer
J' Music

b4 PrizmaixLEDCtrlSetup.exe

@ FlZmalcLEL ST,
5 Software-User-Manual.pdf

@ S>creenshots

Now we are ready to proceed to the setup of the software on this PC.
Remark: after completion of the setup you can delete the
Downloads\Prizmatix LED Ctrl Setup\*.* directory.
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5.2 Setup of Prizmatix LED-Ctrl-STBL PC Software

Locate the "PrizmatixLEDCtrlSetup.exe" file.

Runthe "PrizmatixLEDCtrlSetup.exe" file and follow the instructions as they appear during
the setup process.

Remark: During the installation you will be asked to accept National Instruments license agreement.
Remark: National Instruments advise to disable Windows Fast Startup feature as it can cause problems
with hardware install and remove. During the setup process you will be asked to disable this feature.

At the end of the setup you will be asked to re-boot the system to complete the software installation.

5.3 Setup of USB Device Drivers

The following description is for Windows 10 users.
Users of previous versions of Windows shall refer to Appendix B: Setup of USB Device Drivers for Win 7
and Win 8.
The Windows 10 users with updated and Internet connected PC system can experience fully automatic
setup of the USB drivers. Please follow these simple steps:
a. Please connect the Prizmatix hardware according the hardware user manual and switch the
power switch to ON. If the hardware is LED illuminator decrease the output power to minimum.
b. Type in Search Field: “device manager” and click on it to run this application.
c. Connect the hardware to the computer by the USB cable.

File Action View Help
es mEm B

v % DESKTOP-30ICKFC
& Audio inputs and outputs
& Batteries
0 Bluetooth
\f) Cameras
2 a Computer
=> Device Manager s Disk drives
Control panel I Display adapters
i Firmware
Search the web #r# Human Interface Devices

More ¥

All Apps Documents Web

Best match

== Keyboards

w Mice and other pointing devices
Bl Monitors

P Network adapters

- = Print queues

D Processors

B 5D host adapters

l Security devices

!‘ Software components

B Software devices

L device manager - See web results >

L device manager{ i Sound, video and game controllers

S Storage controllers

i System devices

¥ Universal Serial Bus controllers
§ USB Connector Managers
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d. Immediately after connecting the USB cable Windows will start the standard driver installation
procedure. After few seconds you will see FT232R USB UART device appear in the Device
Manager list and a rectangular message “Setting up a device” will appear at lower right corner
of the screen. After few additional seconds, this device will be replaced by USB Serial Port then
eventually USB Serial Port (COM3) will appear as shown at following picture. Please notice the
COM port number (3 in this example). Please remember this COM port number for future use.

x A &
File Action View Help File Action View Help File Action View Help
s @ Hm B e m Hm B e m D HEHD B EXGE
v % DESKTOP-30ICKFC v % DESKTOP-30ICKFC v &% DESKTOP-30ICKFC

i Audio inputs and outputs § Audio inputs and outputs ¥ Audio inputs and outputs

~ -

% Batteries i Batteries % Batteries

0 Bluetooth 0 Bluetooth G Bluetooth

@ Cameras @ Cameras @ Cameras

8 computer B8 computer B computer

ws Disk drives

¥ Display adapters

! Firmware

99 Human Interface Devices

wm Disk drives

8 Display adapters

M rirmware

4 Human Interface Devices

wa Disk drives

B Display adapters

B rirmware

9 Human Interface Devices

— Keyboards — Keyboards == Keyboards
0 Mice and other pointing devices O Mice and other pointing devices @ Mice and other pointing devices
Bl Monitors B8 Monitors

NSO LK 2 2
v W Ports (COM &LPT)
#@ USB Serial Port (COM3)

D Processors

LY A

K" Other devices
B4 USB Serial Port

n Processors

B8 Monitors

K? Other devices -
B4 FT232R USB UART

D Processors
Bl <N hoct adanterc

£ Setting up a device

We're setting up F123

Once the driver installation is complete, please close the Device Manager. Now the Prizmatix LED Ctrl
software can be used.
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6 System Usage

Choose Prizmatix-LED-CTRL-STBL from Start menu to launch the control software. At the beginning the
small dialog will appear and request to indicate the COM Port number. Please select the correct COM
Port (in this example COM9). See above on finding the COM port by browsing the Device Manager - If
the COM Port does not appear in the list select Refresh (at the top of the list). After few seconds, the
software will establish communication with the device and this dialog box will be closed.

Bu - O b4
File Options About File Options About
Select COM port Select COM port:
Select Port | Refresh v - Select Port [ Refresh bl
¥ Select Port / Refresh
Exit COM3
COMS -

The software has several Graphical User Interfaces (GUI) depending on system specific configuration as
shown in following picture:

File Options About
{ED4Ee —
50— 00000 o
Light Sensor ¥ Ais Aut
. [, ] .
" 80 X Scale Min.
- = NN
e i =10
T N I I O I
50— on 60 Graph OFF
« " N I I O I
e PC Control S g
(o]
= N I I O I
20- Stability 4p-!
: RN
Off 30—
; ] ]
e e ]
On/ Off (F1) COM234 h 10—
Exit 0 | | | | ] | I |
100
Connected Time
LED-Ctrl-STBL software GUI
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If incorrect GUI appear you can change if from menu Options>Configuration. Same menu will appear at
first time you run the software:

File Options About

Configration Hardware

¥ Include PhotoSensor

Save Configuration and Reload

COoM4 i

After first time the software will open with the last settings of COM Port and GUI.

The following picture shows left side of the GUI for LED-Ctrl-STBL software:

Left side of LED-CtrI-STBL software GUI:

1 UHP-... — x
File Options About

[1] - COM Port select control

[2] - Connection indicator:
Green — connected,
Red — not connected
Blue — some error is detected

[3] - Exit software button

a [4] - LED power slider. The slider range is 0-100%. The Digital

Ei N\ 1: to Analog Converter DAC is 12 bit, so this 0-100% is
=

_El converted to 0-4095. See [7] at next picture.

—— [5] - LED power numerical indicator
port
coms = 3 [6] - LED On/Off button
Exit
_‘\—
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The following picture shows the right side of the GUI for LED-Ctrl-STBL software:

File Options About

LED
100~

12
13

[ Y Axs Auto

X5ca n/’_

- d
q

Graph ON //_

: 8

=
m

= Al Select COM port

On/Off (F1) COMZ34 ¥i

2
=

=

7 1 | I |
00 00:00:49 00:01:39 000229 00:03:19 00:04:09
Time

[7] — DAC actual value. Maximum power is at 4095. [8] — Light Sensor value. [9] — Sensor Gain
control. [10] — Switch to enable Data Logging. [11] — Indicator that the LED power is controlled by
LED-Ctrl-STBL software. [12] — Clear Chart button. [13] — Y-Axis-Auto selector. [14] — Control to set
required X-Scale in minutes. [15] — Display the graph button. [16] — Graph legend. [17] — Switch to
enable Stabilization (STBL) mode.

6.1 Manual Mode

The LED controller can be operated without the software. The LED power can be set by the dial.

If computer is connected and user starts the software it is connecting to the controller and the
Connection Indicator [2] shows that the connection is established. In this Manual Mode the user can
observe the DAC settings [7] and Photodiode readings [8], see the graph (press Graph ON knob [15])
and even log the data to a file by turning On the Data Log switch [10]. When Data Log switch turned On
the user will need to provide file name. The data will be saved in SCV format.
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50- I L : Graph ON
DataLlog L
50~ -
Tm 5 1600
0- or 1400 A 8 c D
0 o 1 0 787 693 2182
W 2 1 788 693 2182
200 3 2 791 693 2182
“ 4 B s ThisPC 5 Desktop v B y esktor 4 3 788 692 2182
o 5 4 790 692 2182
) _ - 6 5 790 693 2182
d Organize + New folder - M @ 7 6 703 s3] 2182
- [ Dut 8 7 790 693 2182
.| . e ! 9 8 789 693 2182
53 s Quick access 10 9 788 693 2182
| BB Desktop lo items ma i search 1 10 791 693 2182
Q 12 11 790 693 2182
¥ Downloads 13 12 790 693 2182
— 1 13 788 693 2182
Documents 15 14 789 693 218
& Pictures 16 15 790 693 2182
. 7 16 789 693 2182
D Music 18 17 788 692 2182
— 12 EEEY /a2 212y
File name: | myData ~ | | cawfiles (*.csv) v
oK Cancel

The SCV file can be easily opened by Excel or similar software. The data is arranged in four columns.
Column A —time from start (the points are saved at 1 sec interval)

Column B — Photosensor Visible channel reading 16Bit (0-65536)

Column C - Photosensor NIR channel reading 16Bit (0-65536)

Column D — DAC value 12Bit (0-4095)

The graph shows the spectral response of the photosensor Ch0 is the Visible channel, Ch1 is NIR
channel.

—CH wamsses CH 1

LX)

Normalized Response

EL ] A0 500 &0n 700 800 200 1001} 1100
Waveblength (nm)

6.2 Computer Mode

When user, first time switch the LED on by the ON/OFF button [6], the control is set to the computer.
From this time the manual dial on the hardware will no more effect the LED output power. To go back
to Manual Mode user needs to switch Off the LED controller and turn it On again.

The Slider [4] enables the user to set the LED output power.

Exit button [3] switches the LED OFF and closes the software.
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6.3 Stabilization Mode

When the LED output power need to be stabilized it can be done either in Manual Mode by pressing
the STBL button on the front panel of UHTPLCC-02-STBL controller or Computer Mode by pressing STBL
switch [17].

File Options About

3000
o DA Clear Chart
- [ o | 2600~
" Light Sensar 2600 [~ Y Axis Auto
. 2666
- 2400 X Scale Min_
70=
| 2200 s
o Da 2000 =
L -
40- Off

au
8 8 7

2
15
2

=]
T

Un!
s
= ]
o Select COM port

On [ Off (F1) COM234 v

Exit

88888

| I | I 0
00:00:00 00:00:52 00:01:42 00:02:32 00:03:22 00:04:12
Connected Time

Stability switch [17] and Set Point Yellow graph [18]

When Stability switch [17] is switched to On, the switch color is blinking White/Green until stabilization
software take full control of the system (few seconds) and then became Green. The Yellow graph [18]
is the Set-Point. Before the enabling of the STBL mode it has a value “0”. When the switch [17] moved
to On is rise up to the current Light Sensor value. From this time the light output power (the White
graph) will be stabilized around the Set Point (the Yellow graph).

As can be seen on the next picture, the Digital to Analog Converter (DAC) value (the Red graph) will be
changing to keep the light power (the White graph) as close as possible to the set point (Yellow graph).
From this specific example we see that the power is within 5 Light Sensor units (peak to peak) while
the total mean light value is ¥2668 which means stability of ~0.2% within the set point.
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File Options About
LED 455
© Dot Seceon [~ Y Axis Auto
258 X Scale Min.
70- 3
60- I—] b 20
Data Log
50~ On Graph ON
40- Off
o Fl‘CCuntro\ =
20- Stabi\ity-‘
10- 18-
Off
D_
<
3 Select COM port
On/ Off (F1) COM234 i
EXiT' m_l ] ] ]
00:10:32 00:13:22 00:16:42 00:20:02
Connected Time
Stability switch [17] and Set Point Yellow graph [18]

Menu items:

File>Exit: switchesthe LED OFF and closes the software.

Options>Firmware Update: enables user to update firmware of the USB device. Do not attempt
to update without explicit request from Prizmatix technical support.

Options>Firmware Messages: enables user to see system error messages if any exist
Options>Calibration: Need to be run once upon connection of new different LED head to the
STBL controller.

Help>Prizmatix Website: Displays the Prizmatix website in default browser.
Help>Software User Manual: Display the software user manual in default PDF Reader.
Help>Hardware User Manual: Display the hardware user manual in default PDF Reader
Help>About Hardware..: Shows dialog box with information on connected hardware.
Help>About Software..: Shows dialog box with information on the software.
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Appendix A: Updating LED-Ctrl-STBL Firmware

Don’t perform Firmware Update unless you received explicit
Instructions from the Prizmatix technical team.

Open the Update Firmware dialog by selecting File>Update Firmware from LED-Ctrl-STBL
software menu. The firmware updating is three steps procedure:

Firrmware Update

Step 1 Step 2 Step 3
Select Port: Select Hex File Update Firmware Exit
| -] | Start
coma _F

Step #1: Select the correct COM Port (COM4 in this example). See section “Setup of USB device
drivers” in this manual for details how to find the correct COM port.

Step #2: Select firmware update file “Hex File” by browsing. The typical path will be:
C:\Program Files (x86)\Prizmatix LED CTRL\Firmware\Firmware.hex
or other appropriate *.hex file.

Step #3: Click “Start Update” button to begin update.

You will see many messages running in the window. When the update is completed successfully the
“Thank You” message will appear:

avrdude.exe: verifying ...
avrdude.exe: 13642 bytes of flash verified

avrdude.exe don* Thank you.

Click “Exit” button to close the dialog box.
Your controller is now updated with the latest firmware and ready to go.
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Appendix B: Setup of USB Device Drivers for Win 7 and Win 8

Prizmatix USB device uses Virtual COM port (VCP) by FTDI (www.ftdichip.com) to communicate with
the computer. VCP drivers cause the USB device to appear as an additional COM port available to the
PC.

After successful setup of the Prizmatix PC software, connect the hardware to the computer with the
supplied USB cable. If there is an available Internet connection, Windows will connect to the Windows
Update website and install any suitable driver it finds for the device.

E)nver Saftware Installation ﬁ
—

Installing device driver software

FT232R USB UART L) Searching Windows Update..

Obtaining device driver software from Windows Update might take a while.
Skip obtaining driver software from Windows Update

If the automatic installation takes place there is no need to continue with the procedure outlined
below.

In case you need to install the drivers manually, please download VCP drivers from:
http://www.ftdichip.com/Drivers/VCP.htm

Chose the correct file version from the table Currently Supported VCP Drivers and download the driver.
The file name of the driver will be like:
CDM v2.12.24 WHAQL Certified.zip

Extract the ZIP file to a directory, like:
C:\Users\user\Downloads\CDM v2.12.24 WHQL Certified\

Press the Windows start button to bring up the start menu and select “Control Panel”.

From the Control Panel window select Hardware and Sound and at the next screen select Device
Manager.

In the Device Manager window there will be a device under Other Devices with a yellow warning
symbol to indicate a problem - no driver installed. The text next to the device will be FT232R device.
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.2 Device Manager
File Actien View Help
om0 Hml & F &S

4 2 glunn-PC
W Computer

s Disk drives
& Display adapters
o4 DVD/CD-ROM drives
s Floppy disk drives
w3 Floppy drive controllers
& IDE ATA/ATAPI controllers
— Keybcerds
ﬂ Mice and cther pointing devices
K Monitors
& Network adapters
L Other devices
Ui TTL232R
¥ Ports (COM & LPT)

.

n Processors
& Seund, videc and game controllers
Ml C b daiisms

Right click on the other device (TTL232R in this example) to bring up a menu as shown below.

= Device Manager
File Action View Help
s | @0 HE & B8RS

4 @ glunn-PC
{M Computer
@ Disk drives
&S, Display adapters
&3 DVD/CD-ROM drives
o4 Floppy disk drives
\,H Floppy drive controllers
g IDE ATA/ATAPI controllers

= Keyboards

)3 Mice and other pointing devices
& Monitors

& Network adapters

4 -5 Other devices
i TTL2
¥ Ports (C Update Driver Software..,
B Processo Disable
% Sound, V| Uninstall
M System ¢
# Universa Scan for hardware changes
Properties

From the displayed menu select “Update Driver Software...” This then displays the option for an
automatic search or a manual search.
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) i Update Driver Software - USB Serial Port
How do you want to search for driver software?

< Search automatically for updated driver software
Windows will search your computer and the Internet for the latest driver software
for your device, unless you've disabled this feature in your device installation
settings

< Browse my computer for driver software
Locate and install driver software manually

Cancel
Select the second option to browse manually.

@ |l Update Driver Software - TTL232R

Browse for driver software on your computer

Search for driver software in this location:

RIVERS\CDM 2.04.16 WHQL Certified\CDM 2.04.16 WHQL Certified « Browse...

[Tl Include subfolders

< Let me pick from a list of device drivers on my computer
This list will show installed driver software compatible with the device, and all driver
software in the same category as the device.

In the address box put the exact location where the drivers have been saved to. This may be on a CD or
in a folder on the PC. It is not necessarily the exact same location as shown in the screenshot. The
drivers could have been saved anywhere of the users choosing.

After entering the address select “NEXT” to start the installation.
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W) Ul Update Driver Software - TTL232R

Installing driver software...

When the installation has finished a completion screen is displayed.

W u Update Driver Software - USB Serial Converter
Windows has successfully updated your driver software
Windows has finished installing the driver software for this device:

USB Serial Converter

Press Close to close this window and go back to the Device Manager Window.

= Device Manager e lfa)=

File Action View Help

e M0 BHm & 2 %S
=3 Floppy disk drives -
«d Floppy
L IDE ATA/ATAPI controllers
&2 Keyboards
)'3 Mice and other pointing devices
& Monitors
&F Network adapters

/e controllers

.

W3 Other devices
| USB Serial Port
Y¥ Ports (COM & LPT)
) Processors
% Seund, video and game controllers
1M System devices
4§ Universal Serial Bus controllers
Intel(R) 82801EB USB Universal Host Centroller - 24D2 -
Intel(R) 82801EB USB Universal Host Controller - 24D4
Intel(R) 82801EB USB Universal Host Controller - 24D7
Intel(R) 82801EB USB Universal Host Controller - 24DE
Intel(R) 82801EB USB2 Enhanced Host Contreller - 24DD
USB Root Hub
USB Root Hub
USB Root Hub
USB Root Hub
USB Root Hub
USB Serial Converter

The Device Manager will still show a device under Other Devices but in addition to this there is a new
entry under Universal Serial Bus Controllers indicated in the screenshot above as the USB Serial
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Converter. This indicates the bus layer of the driver is installed. Installing the Virtual Com Port layer of
the driver is almost a repeat of the last few steps.

Right click on the other device (TTL232R in this example) to bring up a menu as shown below.
= Device Manager E

File Action View Help
L o ANl AERN 7 Bl - Y

-3 glunn-PC
M Computer

ca Disk drives
B2 Display adapters
s DVD/CD-ROM drives
&4 Floppy disk drives
EH Floppy drive controllers
€ IDE ATA/ATAPI controllers
&2 Keyboards
| Mice and other pointing devices
I Monitors
& Network adapters
4 -5 Other devices
o ;;;TLC(I Update Driver Software...

B processd Disable

% Sound, v Uninstall

M System ¢

# Universa Scan for hardware changes
Properties

Launches the Update Driver Software Wizard for the selected device.

From the displayed menu select “Update Driver Software...” This then displays the option for an
automatic search or a manual search.

Select the second option to browse manually.

In the address box put the exact location where the drivers have been saved to. This may be on a CD or
in a folder on the PC. It is not necessarily the exact same location as shown in the screenshot. The
drivers could have been saved anywhere of the users choosing.

@ [l Update Driver Software - USB Serial Port

Browse for driver software on your computer

Search for driver software in this location:

RIVERS\CDM 2.04.16 WHQL Certified\CDM 2.04.16 WHQL Certified « Browse... ]

| Include subfolders

< Let me pick from a list of device drivers on my computer
This list will show installed driver software compatible with the device, and all driver
software in the same category as the device.

Cancel ‘
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After entering the address select “NEXT” to start the installation.
When the installation is finished a completion screen is displayed.

Note this screen also displays the COM port assigned to the device. Press Close to close this window
and go back to the Device Manager Window.

=5 Device Manager

File Action View Help

e @m0 Hm & FRS
\:# Floppy drive controllers

> &g IDE ATAJATAPI controllers

D Keyboards

}tﬁ Mice and other pointing devices
» & Monitors

&F Network adapters
47T Ports (COM & LPT)
| 'S Communications Port (COML)
TS Printer Port (LPT1)

! Y2 USB Serial Port (COM3) ¢
) Processors

% Sound, videc and game controllers

(M System devices

This time the Device Manager does not have a FT232R entry under Other Devices but does show
entries under Universal Serial Bus Controllers and Ports (COM & LPT). The above screen shot displays a
correct installation. The device is now ready to use on COM3.

Note: Not all devices will install to COM3. The COM port allocation is determined by the installation
wizard on the basis of the next free com port as designated in the PC registry

Note: the full installation instructions can be found at
AN_119_FTDI_Drivers_lInstallation_Guide_for_Windows7.pdf on www.ftdichip.com website.
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