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Prizmatix LED CTRL Software Description

The Prizmatix LED CTRL (Control) software was developed to enable convenient control
of USB enabled Prizmatix LED light sources on Windows based computers via a USB
connection.

The USB enabled Prizmatix LED sources can be also operated by sending a simple text
string via serial communication COM port from various software packages such as
MicroManager, MetaMorph, LabView, Matlab, HyperTerminal and many other software
packages.

Health and Safety

Prizmatix products are NOT authorized for use as components in life support devices or
systems.

The Prizmatix LED CTRL is intended for use as
laboratory equipment only.

It is not cleared or authorized for clinical use.

Any maintenance shall ONLY be performed by a technician authorized by Prizmatix.
Cellular phones or other radio transmitters should not be used within the vicinity of the
unit.

Setup of the Device

Remove the device from the packaging and inspect the device for loose components or
any signs of damage. Notify Prizmatix if the device appears damaged in any way: do not
install a damaged device.

Package Contents List

The USB enabled Prizmatix LED system can come in various system configurations. Any
software related issues will be described shortly.

Software Installation CD USB-A to USB-B Cable
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Item Description Quantity
USB Type-A to USB Type-B cable for
1 | USB Cable connection of the USB unit to PC 1

Software and Drivers CD -

. Please download additional software drivers
2 | CD with Software ) . ) ) 1
as described in installation section

In case of a multi-channel system the USB device can be installed in an enclosure with
multiple BNC connector outputs. In such a case the package will also contain following
items:

Item Description Quantity
1 | USB device unit USB device unit with multiple BNC connector 1
outputs
Cable to connect the USB device unit to the Depending
2 | BNC-BNC cable Ain input of the LED controller on # of
Channels

Software Setup

The Prizmatix LED CTRL system setup is performed in following steps:
e Setup of Prizmatix LED CTRL PC software
e Setup of USB device drivers

Do not connect the Prizmatix LED CTRL
device to the computer until completing
the software setup process

Setup of Prizmatix LED CTRL PC software

Insert the CD with the installation software into the CD-ROM drive. Browse the CD and
find the file labeled "setup.exe". Run the "setup.exe" file and follow the instructions as
they appear during the setup process and then re-boot the system to complete the
software installation.

Note: during installation the setup software will install the National Instruments
Virtual Instrument Software Architecture (VISA) driver.
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Cable connections of the system

After the setup is successfully completes, connect the Prizmatix LED CTRL device to the
computer with the supplied USB cable.

In case the USB device is installed into the LED controller, the system should look like
this:

USB Prizmatix
LED Controller

In case the USB device is installed in separate enclosure with multiple BNC connector
outputs the system should look like this:

Prizmatix

USB LED Controller

USB-Ctrl
Box

Prizmatix
LED Controller
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Setup of USB device drivers

Immediately after connecting the USB cable Windows will start the standard driver
installation procedure and after a few moments until the process will fail.

Click on the Start Menu, and open up the Control Panel
While in the Control Panel, navigate to System and Security. Next, click on System. Once
the System window is up, open the Device Manager.
An alternative way to get to device manager is to right-click on the My Computer icon
on the desktop and choose Manage from the list.

Explore
Search...
Manage
Scan with AVG Free

Map Network Drive...
Disconnect Network Drive...

Create Shortcut

Choose Device Manager on the left panel and watch for “?” unknown device in the list in

the right panel.

9, Computer Management

e+ OE R

= Computer Management (Lox
= & System Tools

+ ({4 Event Viewer

+ g3) Shared Foiders

+ Local Users and Groug

1 Device Manager

+ @ Removabie Storage
@ Disk Defragmenter
& Disk Management

+ [ Services and Appications
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i Computer

< Disk drives

¥ Display adapters

2 DVD/CD-ROM drives
84 Human Interface Devices

& IDE ATA/ATAP] controlers

& IEEE 1394 Bus host controlers
52 Imaging devices

“» Keyboards

") Mice and other pointing devices
R Modems

% Monkors

B Network adapters
&} Other devices

%3 USB Device
+ B PCMCA adapters
- i) Portabie Devices
W Nokia €71

# 5 Ports (COM & LPT)
+ B Processors
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Right click on the unknown device and choose the "Update Driver" option. The
Hardware Update Wizard window will appear

Hardware Update Wizard

Welcome to the Hardware Update
H Wizard

Windows will search for current and updated software by
looking on your computer, on the hardware installation CD, or on
the Windows Update Web site (with your permission).

Read our privacy policy

Can Windows connect to Windows Update to search for
software?

O Yes, this time only

Yes, now and every time | connect a device
(®) No, not this time

Click Next to continue.

Nexst jQ Cancel

Choose “No, not this time” and click Next. At next screen choose “Install from a list or
specific location” and click Next.

Hardware Update Wizard

This wizard helps you install software for:

Arduino Uno

) your hardware came with an installation CD
&’ or floppy disk. insert it now.

\What do you want the wizard to do?

O Install the software automatically (Recommended)
(¥ Install from a list or specific location (Advanced)

Click Next to continue.

[ < Back ”|\ Ne%__}[ Cancel ]

On next screen choose “Include this location in the search” and navigate by browsing to
(you can copy and paste the address to the windows navigator)

C:\Program Files\Prizmatix LED CTRL\Drivers
and click on Next.
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A new window will appear:

Please wail while the wizard installs the software.

rdware Wizard

‘J_f Prizmatix DR\

If you use Win XP you may see following window, click “Continue Anyway”:

Hardware Installation

! 5 The software you are installing for this hardware:

Prizmatix Pulser

has not passed Windows Logo testing to verify its compatibility with
Windows XP. (Tell me why this testing is important)

Continuing your i llation of this soft may impair or
d bilize the top ion of your sy either

immediately or in the future. Mi ft strongly d:
that you stop this installation now and contact the hardware
vendor for software that has p d Wind Logo testi

| !
[ Continue Anyway _]I STOP Installation ]

After few seconds the procedure will be completed and final window appear:

Found New Hardware Wizard

Completing the Found New Hardware
Wizard

The wizard has finished installing the software for

3 Prizmatix DRV

Click Finish to close the wizard.

Click on “Finish” to complete the setup.
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Now open the Device Manager. The Prizmatix DRV device will be found in the list in the
right panel. Please notice the COM port number (25 in this example).

4 |f} System Tools
(® Task Scheduler
- 8] Event Viewer
@ Shared Folders
i & Local Users and Groups
®) Performance
)
4 &3 Storage
=f Disk Management
s Services and Applications

— Keyboards

_¥ Mice and other pointing devices
K Monitors

. &¥ Network adapters
- -|{3) Other devices

T¥ Ports (COM & LPT)
Y¥" ECP Printer Port (LPT1)
Y3 Prizmatix DRV (CO

> m Processors

> Smart card readers

> £ Sound. video and name controllers

A Computer Management . E@ﬂ
File Action View Help

e 2E0 BE &

A Computer Management (Local) {-.g Imaging devices 4 | Actions

11

Device Manager «
More Acti.. »

— e

Once the driver installation is complete the Prizmatix LED CTRL software can be used.

System Usage

Choose Prizmatix LED CTRL from Start menu to launch the control software. The
software has several Graphical User Interfaces depending on number of LEDs you

control.
{3 o CRL L] e S ==
dooligle ST . file Edit Operate Tools Window Help 1
File Help /] see W
nl 2
100- 100~
| "”‘ 80° 80:
o o]  «
60 40 40:
w-f 20- 20-
39'3 o; U;
o2 ;0' J 0
JU_.. 450A 4508
v 1
|
o - SelectCOMpor: REINE =
Iszmaful.ED CTRL Ver, 231 COMS6 le |
Single Channel LED CTRL Multi Channel LED CTRL
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The main screen will appear. Select the appropriate COM port from the list (COM69 in
this example) - See above on finding the COM port by browsing the Device Manager - If
the COM Port does not appear in the list select Refresh (at the end of the list).

<& LED CTRL |3_]éj

File Help
100-
80-
60-
40-
5

2o§|
o
g5

EXIT

Select COM port: fCOM69  ~| <

Prizmatix LED CTRL Ver. 2.3.1

In case of a multi-channel system the software will only show the active channels. All
inactive channels will be grayed.

The Slider enables the user to set the LED output power.

The ON/OFF button switches the LED ON/OFF

Exit button switches the LED OFF and closes the software.

Menu items:

File>Update Firmware: enables user to update firmware of the USB device. Do
not attempt to update without explicit request from Prizmatix technical support.
File>Exit: switches the LED OFF and closes the software.

Help>User Manual: Display the user manual in Acrobat Reader.
Help>Prizmatix Website: Displays the Prizmatix website in default browser.
Help>About LED CTRL: Shows the about dialog box.
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Using the HyperTerminal software

The Prizmatix LED CTRL can be used with any HyperTerminal-like software capable of
sending and receiving simple ASCIl commands over serial RS232 or USB interface.
In order to send commands to the Pulser the COM port should be configured to
following settings:

Bits per second: 57600

Data bits: 8

Parity: None

Stop Bits: 1

Flow Control: None

These setting can be changed at the Device Manager.
Right Click the Prizmatix DRV device and select Properties from the list:

L¥ Network adapters
4 73 Ports (COM & LPT)
- YZ¥ ECP Printer Port (LPT1)
'? Intel(R) Active Management Technology - SOL (COM3)

"' Prizmatix DRV Update Driver Software...

D Processors Disable
¥ Sound, video and

4 Uninstall
&7 Storage controller
& System devices Scan for hardware changes
@ Universal Serial Bu Properties

The COM Port settings can be configured at the Port Settings tab:

Prizmatix DRV (COM®6) Properties ﬁ
General | Port Settings |Driver| DeLaiIs|
Bits per second: [57&00 v]
Data bits: [8 ']
Parity: [Nune V]
W Stop bits: [1 V]
i
Elow control: [None V]
[ Advanced ] [ Restore Defaults ]
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Note: The number of channels in the system can vary from 1 to 6. The control
commands should include the correct number of channels. For example if your system
has 3 channels (3 LEDs) you need include all LED1, LED2, LED3 in the command
string

The Prizmatix LED CTRL can accept commands sent to the serial COM port in following
format for 1 or 2 channels (for 1 LED system change only Ch1):

M LED1,LED2,0Q@

Where

M - Prefix (no space or comma needed after the “M”)

LED1, LED2 -the digital potentiometer values for LED power control

0@ - markthe end of command

For 4 channels:
M LED1,LED2,LED3,LED4, 0@

Notes:

e Systems with 1 or 2 channels use 1024 step digital potentiometers therefore the
valid values for LED are numbers between 0 to 1023. System with 3,4,5 and 6
channels use 256 step digital potentiometers therefore the valid values for LED
are numbers between 0 to 255

e M — Must appear at beginning of the command (no space or comma needed
after the “M”)

e 0@ — Must appear at end of the command

e Nocomma“,” needed before @ character

e No spaces between the characters or numbers in the string

Examples (for 1 or 2 LED system):
For 1 LED system change only Ch1.:

MO, 0, 0@ - LED will be at min. power — OFF

M251, 0, 0@ - Channel #1 is ON with digital potentiometer value of 251, Channel #2 is
OFF

MO, 1023, 0@Q --Channel #1 is OFF, Channel #2 is ON with digital potentiometer set to
1023 value (maximum value).

Version

Send command:

V —version

The response shall be version number e.g. 2.5
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Appendix A: Updating LED-CTRL Firmware

Don’t perform Firmware Update unless you received explicit
Instructions from the Prizmatix technical team.

Open the Update Firmware dialog by selecting File>Update Firmware from LED-
CTRL software menu.

A& Prizmatix Firmware Update 02.vi - l &

|1 I %com1 B
Select Firmware Updating File (*.hex)

Selected Firmware Updating File (*.hex):
C:\Program Files (x86)\Prizmatix LED CTRL - Ver 2.4\Firmware\UHP_T_CTRLhex

| Start Update Quit without Update

1) Select the correct COM Port (COM1 in this example). See section “Setup of
Pulser Device Drivers” in this manual for details how to find the Pulser COM port.

2) Click “Select Firmware Updating File (*.hex)” button and browse to
C:\Program Files (x86)\Prizmatix LED CTRL - Ver
2.5\Firmware\UHP T CTRL Firmware.hex
or other appropriate *.hex file.

3) Click “Start Update” button to begin update.

When the update is completed successfully the following dialog box will appear:

Thank you for updating!

| Close |

Click “Close”.
Your Pulser is now updated with the latest firmware and ready to go.
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