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2 Prizmatix LED-Ctrl Software Description 
The Prizmatix UHP-T-LED-CTRL (Control) software was developed to enable convenient control of USB 
enabled UHPTLCC-02-USB LED controllers on Windows based computers via a USB connection.  
The USB enabled Prizmatix LED sources can be also operated by sending a simple text string via serial 
communication COM port from various software packages such as MicroManager, MetaMorph, 
LabView, Matlab, HyperTerminal and many other software packages. API and code examples are 
available upon request. 

3 Health and Safety 
Prizmatix products are NOT authorized for use as components in life support devices or systems. 

The Prizmatix LED CTRL is intended for use as laboratory 
equipment only. 

   It is not cleared or authorized for clinical use. 
 

4 Setup of the Hardware 
For setup of the hardware (LED head, LED controller etc.) please refer to the specific LED illuminator 
User-Manual. In this document only software related aspect will be discussed.  
Please ensure that you have received appropriate USB cable to connect the LED controller to the 
computer. 

 

5 Software Setup 
The Prizmatix LED CTRL system setup is performed in following steps: 

• Download of the compressed software (ZIP file). 

• Setup of Prizmatix UHP-T-LED-CTRL software 

• Setup of USB device drivers 
 

Do not connect the USB cable to the computer until 
completing the software setup process 
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5.1 Download of the Compressed Software 

The software is available at Prizmatix website: 
prizmatix.com/software.htm 
Please refer to the software related label on the bottom of the LED controller. The label indicates the 
specific link that shall be used for download. 
Click on the link, you will see the ZIP file inside Dropbox.  
Click on the small menu [▪▪▪] at right side of the ZIP file name. As the menu opens chose Download. 
The ZIP file will download to your default download folder  
Typically:  C:\Users\YourName\Downloads 
Open the download folder and right click on the ZIP file, a popup menu will open. 
Chose Extract All…  

The following dialog box will appear. By default it will suggest to create a new folder in your 
Downloads folder, which is typically good practice. Press Extract button to continue. 
 

 
 
After completion of this step browse the folder where the files where extracted and locate “setup.exe” 
Now we are ready to proceed to the setup of the software on this PC.  

5.2 Setup of Prizmatix LED-Ctrl PC Software 

As explained in previous chapter, locate the "PrizmatixLEDCtrlSetup.exe" file. 
Run the "PrizmatixLEDCtrlSetup.exe" file and follow the instructions as they appear during 
the setup process.  
Remark: During the installation you will be asked to accept National Instruments license agreement. 
Remark: National Instruments advise to disable Windows Fast Startup feature as it can cause problems 
with hardware install and remove. During the setup process you will be asked to disable this feature.  
 
At the end of the setup you will be asked to re-boot the system to complete the software installation. 

https://www.prizmatix.com/software.htm


 

Prizmatix 
 

5 | P a g e                                  UHP-T-LED-CTRL User Manual  
 

5.3 Setup of USB Device Drivers 

The following description is for Windows 10 users.  
Users of previous versions of Windows shall refer to Appendix B: Setup of USB Device Drivers for Win 7 
and Win 8. 
The Windows 10 users with updated and Internet connected PC system can experience fully automatic 
setup of the USB drivers. Please follow these simple steps: 

a. Please connect the Prizmatix hardware according the hardware user manual and switch the 
power switch to ON. If the hardware is LED illuminator decrease the output power to minimum. 

b. Type in Search Field: “device manager” and click on it to run this application. 
c. Connect the hardware to the computer by the USB cable. 

 

 

 

 
d. Immediately after connecting the USB cable Windows will start the standard driver installation 

procedure. After few seconds you will see FT232R USB UART device appear in the Device 
Manager list and a rectangular message “Setting up a device” will appear at lower right corner 
of the screen. After few additional seconds, this device will be replaced by USB Serial Port then 
eventually USB Serial Port (COM3) will appear as shown at following picture.  Please notice the 
COM port number (3 in this example). Please remember this COM port number for future use. 
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Once the driver installation is complete, please close the Device Manager. Now the Prizmatix LED Ctrl 
software can be used. 

  



 

Prizmatix 
 

7 | P a g e                                  UHP-T-LED-CTRL User Manual  
 

6 System Usage 

Choose Prizmatix LED CTRL from Start menu to launch the control software. At the beginning the small 
dialog will appear and request to indicate the COM Port number. Please select the correct COM Port 
(in this example COM9). See above on finding the COM port by browsing the Device Manager - If the 
COM Port does not appear in the list select Refresh (at the top of the list). After few seconds, the 
software will establish communication with the device and this dialog box will be closed. 

 

The software has several Graphical User Interfaces (GUI) depending on system specific configuration as 
shown in following picture: 

  
LED-Ctrl software GUI 
without photo-sensor 

LED-Ctrl software GUI with photo-sensor 
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If incorrect GUI appear you can change if from menu Options>Configuration. Same menu will appear at 
first time you run the software: 

 

After first time the software will open with the last settings of COM Port and GUI. 

The following picture shows GUI for LED-Ctrl software without photo-sensor: 
 

 

LED-Ctrl software GUI without photo-sensor: 
[1] - COM Port select control 
[2] - Connection indicator:  

Green – connected,  
Red – not connected 

[3] - Exit software button 
[4] - LED power slider. The slider range is 0-100%. The Digital 
to Analog Converter DAC is 12 bit, so this 0-100% is 
converted to 0-4095. See [7] at next picture.  
[5] - LED power numerical indicator 
[6] - LED On/Off button 
 

  
 
The following picture shows GUI for LED-Ctrl software with photo-sensor: 
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[7] – DAC actual value. Maximum power is at 4095. [8] – Light Sensor value. The Light Sensor is 
16Bit device therefore max. value is 65535. [9] – Sensor Gain control. [10] – Switch to enable Data 
logging. [11] – Indicator that the LED power is controlled by LED-Ctrl software. [12] – Clear Chart 
button. [13] – Y-Axis-Auto selector. [14] – Control to set required X-Scale in minutes. [15] – Display 
the graph button. [16] – Graph legend. 

6.1 Manual Mode 

The LED controller can be operated without the software. The LED power can be set by the dial. 
If computer is connected and user starts the software it is connecting to the controller and the 
Connection Indicator [2] shows that the connection is established. In this Manual Mode the user can 
observe the DAC settings [7] and Photodiode readings [8], see the graph (press Graph ON knob [15]) 
and even log the data to a file by turning On the Data Log switch [10]. When Data Log switch turned On 
the user will need to provide file name. The data will be saved in SCV format. 
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The SCV file can be easily opened by Excel or similar software. The data is arranged in four columns. 
Column A – time from start (the points are saved at 1 sec interval) 
Column A – Photosensor Visible channel reading 16Bit (0-65536) 
Column A – Photosensor NIR channel reading 16Bit (0-65536) 
Column A – DAC value 12Bit (0-4095) 
The graph shows the spectral response of the photosensor Ch0 is the Visible channel, Ch1 is NIR 
channel. 

 
 

6.2 Computer Mode 

When user, first time switch the LED on by the ON/OFF button [6], the control is set to the computer. 
From this time the manual dial on the hardware will no more effect the LED output power. To go back 
to Manual Mode user needs to switch Off the LED controller and turn it On again. 
The Slider [4] enables the user to set the LED output power. 
Exit button [3] switches the LED OFF and closes the software. 
 
Menu items: 
File>Update Firmware: enables user to update firmware of the USB device. Do not attempt to 
update without explicit request from Prizmatix technical support. 
File>Exit: switches the LED OFF and closes the software. 
Help>User Manual: Display the user manual in Acrobat Reader. 

Help>Prizmatix Website: Displays the Prizmatix website in default browser. 

Help>About LED CTRL: Shows the about dialog box. 
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Appendix A: Updating LED-Ctrl Firmware 
 

Don’t perform Firmware Update unless you received explicit  
Instructions from the Prizmatix technical team. 

 

Open the Update Firmware dialog by selecting File>Update Firmware from LED-Ctrl software 
menu. The firmware updating is three steps procedure:  
 

 
 

Step #1: Select the correct COM Port (COM4 in this example). See section “Setup of USB device 
drivers” in this manual for details how to find the correct COM port. 

 
Step #2: Select firmware update file “Hex File” by browsing. The typical path will be: 
C:\Program Files (x86)\Prizmatix LED CTRL\Firmware\Firmware.hex 

or other appropriate *.hex file. 
 
Step #3: Click “Start Update” button to begin update. 

 
You will see many messages running in the window. When the update is completed successfully the 
“Thank You” message will appear: 
 

 
 

Click “Exit” button to close the dialog box. 
Your controller is now updated with the latest firmware and ready to go. 
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Appendix B: Setup of USB Device Drivers for Win 7 and Win 8 
 
Prizmatix USB device uses Virtual COM port (VCP) by FTDI (www.ftdichip.com) to communicate with 
the computer. VCP drivers cause the USB device to appear as an additional COM port available to the 
PC.  
After successful setup of the Prizmatix PC software, connect the hardware to the computer with the 
supplied USB cable. If there is an available Internet connection, Windows will connect to the Windows 
Update website and install any suitable driver it finds for the device.  
 

 
 

If the automatic installation takes place there is no need to continue with the procedure outlined 
below. 
 
In case you need to install the drivers manually, please download VCP drivers from: 
http://www.ftdichip.com/Drivers/VCP.htm  
Chose the correct file version from the table Currently Supported VCP Drivers and download the driver. 
The file name of the driver will be like: 
CDM v2.12.24 WHQL Certified.zip 
Extract the ZIP file to a directory, like: 
C:\Users\user\Downloads\CDM v2.12.24 WHQL Certified\ 

 
Press the Windows start button to bring up the start menu and select “Control Panel”. 
 
From the Control Panel window select Hardware and Sound and at the next screen select Device 
Manager. 
 
In the Device Manager window there will be a device under Other Devices with a yellow warning 
symbol to indicate a problem - no driver installed. The text next to the device will be FT232R device. 
 

http://www.ftdichip.com/
http://www.ftdichip.com/Drivers/VCP.htm
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Right click on the other device (TTL232R in this example) to bring up a menu as shown below. 
 

 
 

 

From the displayed menu select “Update Driver Software…” This then displays the option for an 
automatic search or a manual search. 
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Select the second option to browse manually. 
 
 

 

 
 
In the address box put the exact location where the drivers have been saved to. This may be on a CD or 
in a folder on the PC. It is not necessarily the exact same location as shown in the screenshot. The 
drivers could have been saved anywhere of the users choosing.  
After entering the address select “NEXT” to start the installation. 
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When the installation has finished a completion screen is displayed. 
 

 
 
Press Close to close this window and go back to the Device Manager Window. 
 

 
 
The Device Manager will still show a device under Other Devices but in addition to this there is a new 
entry under Universal Serial Bus Controllers indicated in the screenshot above as the USB Serial 
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Converter. This indicates the bus layer of the driver is installed. Installing the Virtual Com Port layer of 
the driver is almost a repeat of the last few steps. 
 
Right click on the other device (TTL232R in this example) to bring up a menu as shown below. 

 
 
From the displayed menu select “Update Driver Software…” This then displays the option for an 
automatic search or a manual search. 
Select the second option to browse manually. 
In the address box put the exact location where the drivers have been saved to. This may be on a CD or 
in a folder on the PC. It is not necessarily the exact same location as shown in the screenshot. The 
drivers could have been saved anywhere of the users choosing.  
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After entering the address select “NEXT” to start the installation. 
When the installation is finished a completion screen is displayed. 
 
Note this screen also displays the COM port assigned to the device. Press Close to close this window 
and go back to the Device Manager Window. 
 

 
 
This time the Device Manager does not have a FT232R entry under Other Devices but does show 
entries under Universal Serial Bus Controllers and Ports (COM & LPT). The above screen shot displays a 
correct installation. The device is now ready to use on COM3.  
 
Note: Not all devices will install to COM3. The COM port allocation is determined by the installation 
wizard on the basis of the next free com port as designated in the PC registry 
 
Note: the full installation instructions can be found at 
AN_119_FTDI_Drivers_Installation_Guide_for_Windows7.pdf on www.ftdichip.com website. 
 
 

 
 

http://www.ftdichip.com/

